역사 ¶
IPv4 protocol 은 1981년에 RFC791에 의해서 정의되었다.
용어정의 ¶
- RTT : Round-Trip Time
- ICMP : Internet Control Message Protocol
Class 구분 ¶
- A class (0.0.0.0 ~ 127.255.255.255)
128개의 네트웍으로 구성되며 각 네트웍은 16,777,216개의 주소를 갖는다.
| 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 |
| 0 | NetID | HostID |
- B class (128.0.0.0 ~ 191.255.255.255)
16,384개의 네트웍으로 구성되며 각 네트웍은 65,536개의 주소를 갖는다.
| 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 |
| 1 | 0 | NetID | HostID |
- C class (192.0.0.0 ~ 223.255.255.255)
2,097,152개의 네트웍으로 구성되며 각 네트웍은 256개의 주소를 갖는다.
| 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 |
| 1 | 1 | 0 | NetID | HostID |
- D class (224.0.0.0 ~ 239.255.255.255)
Multicast를 위한 주소로 사용된다.
| 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 |
| 1 | 1 | 1 | 0 | Multicast group ID |
- E class (240.0.0.0 ~ 247.255.255.255)
미래를 위하여 사용을 보류한 영역이다.
| 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 |
| 1 | 1 | 1 | 1 | 0 | Reserved for future use |
사설 IP (Private IP) 대역 ¶
IANA(Internet Assigned Numbers Authority, 국제 주소관리 기구)는 다음과 같은 사설 IP주소(Private IP)를 예약해 두었으며, 이의 사용을 강력히 권고하고 있습니다.
- Class A 규모 : 10/8(10.0.0.0∼10.255.255.255)
- Class B 규모 : 172.16/12(172.16.0.0∼172.31.255.255)
- Class C 규모 : 192.168/16(192.168.0.0∼192.168.255.255)
이 주소들은 전세계 어디에도 할당되지 않는 특수목적의 IP주소이므로, 비록 기업내부에 이미 할당받은 공인 IP 주소가 있다 하더라도 주소 충돌의 위험성은 없습니다. 단, 이 기업이 인터넷으로 다른 기업과 통신하려 할 때는 이 사설 IP주소를 공인(Public) IP주소로 변환하여 통신하여야 하며, 특히, Private IP주소가 외부로 라우팅되지 않도록 조심해야 합니다.
Private-to-public IP주소 변환을 위해서는 NATs(Network Address Translators)와 같은 Gateway System(주로 방화벽제품에서 사용)을 사용하여야 합니다. 즉, 내부적으로 private address를 사용하도록 설정되어 있는 전산기가 외부 인터넷상의 전산기와 통신하려 할때는, 이 gateway 시스템에서 private IP주소를 public IP주소로 변환해 줍니다. 이때 gateway 시스템은 적정 수량의 필요한 public IP주소 pool을 유지하고 있어야 하므로, 이에 필요한 public IP주소는 인터넷주소할당조직(Internet Registry)으로부터 할당받아야 합니다.
이 private 주소 사용에 있어서의 장점은 KRNIC, ISP등 누구에게도 주소공간 할당 신청을 하지 않음으로서, 까다로운 심사절차 를 거치지 않아도 됩니다. 즉, 기업내부의 모든 host수를 조사하고, CIDR/VLSM을 적용한 세밀한 networking plan을 세우고, 상대적으로 다루기 어려운 OSPF같은 프로토콜을 사용하여야 하는 등의 불편이 따르지 않게 됩니다.
조직내부 IP주소공간 관리 편의를 위해, 필요이상으로 충분히 넉넉한 주소공간을 자유롭게 사용할 수 있습니다. 즉, 5개의 host가 필요한 subnet에 대해서도 미래를 대비하여 /24를 할당할 수 있습니다. 수시로 변하는 조직변동, 전산기들의 이동, 재배치 등등에 대해서도 별로 걱정할 필요로 없습니다. Private IP주소를 사용하게 되고, 주로 NATs 시스템이 방화벽기능을 포함하고 있으므로, 상대적으로 보안성이 강화됩니다.
그러나, 전세계 인터넷도메인이름 시스템과 연결되는 external용과 기업 내부용의 internal Domain Name server를 운영해야 할 것이며, 외부 공개용으로 반드시 public IP주소가 필요한 시스템과 그렇지 않은 시스템으로 구분하여, 외부 공개용 시스템에는 public IP 주소를 static하게 지정하여야 할 것입니다. 최근 private IP주소를 활용하는 라우터, 시스템 등이 많이 출시되고 있는 추세이므로, 이의 사용을 적극 권장한다. 보다 자세한 내용은 RFC1597을 참조할수 있습니다.
IP (Internet Protocol) header ¶
- IP datagram은 다음과 같은 형식을 가진다.
| 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 | Description |
| 4bit Version | 4bit Header length / 4 | 8bit Type of service (TOS) | 16bit Total length (in bytes) | 20 bytes | 20~60 bytes |
| 16-bit Identification | 3-bit Flags | 13bit Fragment offset |
| 8bit Time to live (TTL) | 8bit Protocol | 16bit Header checksum |
| 32bit 출발지 IP 주소 |
| 32bit 목적지 IP 주소 |
| Options (if any) | 0~40 bytes |
| Data | Total length - Header length |
- 4-bit Header length는 4의 배수로 해석한다. 즉, 1이 4바이트를 뜻한다. 최대 4-bit로 15까지 값을 지정할수 있으므로 15x4=60 bytes가 최대값이고 이것은 "Options (if any)" 가 60-20=40 bytes를 넘지 못한다는 의미이기도 하다.
- 8-bit Protocol 항목에는 다음의 값들을 사용할수 있다. (참고:
http://www.iana.org/assignments/protocol-numbers )
| Decimal | Keyword | Protocol | References |
| 0 | HOPOPT | IPv6 Hop-by-Hop Option | (RFC1883) |
| 1 | ICMP | Internet Control Message | (RFC792) |
| 2 | IGMP | Internet Group Management | (RFC1112) |
| 3 | GGP | Gateway-to-Gateway | (RFC823) |
| 4 | IP | IP in IP (encapsulation) | (RFC2003) |
| 5 | ST | Stream | (RFC1190)(RFC1819) |
| 6 | TCP | Transmission Control | (RFC793) |
| 7 | CBT | CBT | (Ballardie) |
| 8 | EGP | Exterior Gateway Protocol | (RFC888)(DLM1) |
| 9 | IGP | any private interior gateway (used by Cisco for their IGRP) | (IANA) |
| 10 | BBN-RCC-MON | BBN RCC Monitoring | (SGC) |
| 11 | NVP-II | Network Voice Protocol | (RFC741)(SC3) |
| 12 | PUP | PUP | (PUP)(XEROX) |
| 13 | ARGUS | ARGUS | (RWS4) |
| 14 | EMCON | EMCON | (BN7) |
| 15 | XNET | Cross Net Debugger | (IEN158)(JFH2) |
| 16 | CHAOS | Chaos | (NC3) |
| 17 | UDP | User Datagram | (RFC768)(JBP) |
| 18 | MUX | Multiplexing | (IEN90)(JBP) |
| 19 | DCN-MEAS | DCN Measurement Subsystems | (DLM1) |
| 20 | HMP | Host Monitoring | (RFC869)(RH6) |
| 21 | PRM | Packet Radio Measurement | (ZSU) |
| 22 | XNS-IDP | XEROX NS IDP | (ETHERNET)(XEROX) |
| 23 | TRUNK-1 | Trunk-1 | (BWB6) |
| 24 | TRUNK-2 | Trunk-2 | (BWB6) |
| 25 | LEAF-1 | Leaf-1 | (BWB6) |
| 26 | LEAF-2 | Leaf-2 | (BWB6) |
| 27 | RDP | Reliable Data Protocol | (RFC908)(RH6) |
| 28 | IRTP | Internet Reliable Transaction | (RFC938)(TXM) |
| 29 | ISO-TP4 | ISO Transport Protocol Class 4 | (RFC905)(RC77) |
| 30 | NETBLT | Bulk Data Transfer Protocol | (RFC969)(DDC1) |
| 31 | MFE-NSP | MFE Network Services Protocol | (MFENET)(BCH2) |
| 32 | MERIT-INP | MERIT Internodal Protocol | (HWB) |
| 33 | DCCP | Datagram Congestion Control Protocol | (RFC4340) |
| 34 | 3PC | Third Party Connect Protocol | (SAF3) |
| 35 | IDPR | Inter-Domain Policy Routing Protocol | (MXS1) |
| 36 | XTP | XTP | (GXC) |
| 37 | DDP | Datagram Delivery Protocol | (WXC) |
| 38 | IDPR-CMTP | IDPR Control Message Transport Proto | (MXS1) |
| 39 | TP++ | TP++ Transport Protocol | (DXF) |
| 40 | IL | IL Transport Protocol | (Presotto) |
| 41 | IPv6 | Ipv6 | (Deering) |
| 42 | SDRP | Source Demand Routing Protocol | (DXE1) |
| 43 | IPv6-Route | Routing Header for IPv6 | (Deering) |
| 44 | IPv6-Frag | Fragment Header for IPv6 | (Deering) |
| 45 | IDRP | Inter-Domain Routing Protocol | (Hares) |
| 46 | RSVP | Reservation Protocol | (Braden) |
| 47 | GRE | General Routing Encapsulation | (Li) |
| 48 | DSR | Dynamic Source Routing Protocol | (RFC4728) |
| 49 | BNA | BNA | (Salamon) |
| 50 | ESP | Encap Security Payload | (RFC2406) |
| 51 | AH | Authentication Header | (RFC2402) |
| 52 | I-NLSP | Integrated Net Layer Security TUBA | (GLENN) |
| 53 | SWIPE | IP with Encryption | (JI6) |
| 54 | NARP | NBMA Address Resolution Protocol | (RFC1735) |
| 55 | MOBILE | IP Mobility | (Perkins) |
| 56 | TLSP | Transport Layer Security Protocol using Kryptonet key management | (Oberg) |
| 57 | SKIP | SKIP | (Markson) |
| 58 | IPv6-ICMP | ICMP for IPv6 | (RFC1883) |
| 59 | IPv6-NoNxt | No Next Header for IPv6 | (RFC1883) |
| 60 | IPv6-Opts | Destination Options for IPv6 | (RFC1883) |
| 61 | | any host internal protocol | (IANA) |
| 62 | CFTP | CFTP | (CFTP)(HCF2) |
| 63 | | any local network | (IANA) |
| 64 | SAT-EXPAK | SATNET and Backroom EXPAK | (SHB) |
| 65 | KRYPTOLAN | Kryptolan | (PXL1) |
| 66 | RVD | MIT Remote Virtual Disk Protocol | (MBG) |
| 67 | IPPC | Internet Pluribus Packet Core | (SHB) |
| 68 | | any distributed file system | (IANA) |
| 69 | SAT-MON | SATNET Monitoring | (SHB) |
| 70 | VISA | VISA Protocol | (GXT1) |
| 71 | IPCV | Internet Packet Core Utility | (SHB) |
| 72 | CPNX | Computer Protocol Network Executive | (DXM2) |
| 73 | CPHB | Computer Protocol Heart Beat | (DXM2) |
| 74 | WSN | Wang Span Network | (VXD) |
| 75 | PVP | Packet Video Protocol | (SC3) |
| 76 | BR-SAT-MON | Backroom SATNET Monitoring | (SHB) |
| 77 | SUN-ND | SUN ND PROTOCOL-Temporary | (WM3) |
| 78 | WB-MON | WIDEBAND Monitoring | (SHB) |
| 79 | WB-EXPAK | WIDEBAND EXPAK | (SHB) |
| 80 | ISO-IP | ISO Internet Protocol | (MTR) |
| 81 | VMTP | VMTP | (DRC3) |
| 82 | SECURE-VMTP | SECURE-VMTP | (DRC3) |
| 83 | VINES | VINES | (BXH) |
| 84 | TTP | TTP | (JXS) |
| 85 | NSFNET-IGP | NSFNET-IGP | (HWB) |
| 86 | DGP | Dissimilar Gateway Protocol | (DGP)(ML109) |
| 87 | TCF | TCF | (GAL5) |
| 88 | EIGRP | EIGRP | (CISCO)(GXS) |
| 89 | OSPFIGP | OSPFIGP | (RFC1583)(JTM4) |
| 90 | Sprite-RPC | Sprite RPC Protocol | (SPRITE)(BXW) |
| 91 | LARP | Locus Address Resolution Protocol | (BXH) |
| 92 | MTP | Multicast Transport Protocol | (SXA) |
| 93 | AX.25 | AX.25 Frames | (BK29) |
| 94 | IPIP | IP-within-IP Encapsulation Protocol | (JI6) |
| 95 | MICP | Mobile Internetworking Control Pro. | (JI6) |
| 96 | SCC-SP | Semaphore Communications Sec. Pro. | (HXH) |
| 97 | ETHERIP | Ethernet-within-IP Encapsulation | (RFC3378) |
| 98 | ENCAP | Encapsulation Header | (RFC1241,RXB3) |
| 99 | | any private encryption scheme | (IANA) |
| 100 | GMTP | GMTP | (RXB5) |
| 101 | IFMP | Ipsilon Flow Management Protocol | (Hinden) |
| 102 | PNNI | PNNI over IP | (Callon) |
| 103 | PIM | Protocol Independent Multicast | (Farinacci) |
| 104 | ARIS | ARIS | (Feldman) |
| 105 | SCPS | SCPS | (Durst) |
| 106 | QNX | QNX | (Hunter) |
| 107 | A/N | Active Networks | (Braden) |
| 108 | IPComp | IP Payload Compression Protocol | (RFC2393) |
| 109 | SNP | Sitara Networks Protocol | (Sridhar) |
| 110 | Compaq-Peer | Compaq Peer Protocol | (Volpe) |
| 111 | IPX-in-IP | IPX in IP | (Lee) |
| 112 | VRRP | Virtual Router Redundancy Protocol | (RFC3768) |
| 113 | PGM | PGM Reliable Transport Protocol | (Speakman) |
| 114 | | any 0-hop protocol | (IANA) |
| 115 | L2TP | Layer Two Tunneling Protocol | (Aboba) |
| 116 | DDX | D-II Data Exchange (DDX) | (Worley) |
| 117 | IATP | Interactive Agent Transfer Protocol | (Murphy) |
| 118 | STP | Schedule Transfer Protocol | (JMP) |
| 119 | SRP | SpectraLink Radio Protocol | (Hamilton) |
| 120 | UTI | UTI | (Lothberg) |
| 121 | SMP | Simple Message Protocol | (Ekblad) |
| 122 | SM | SM | (Crowcroft) |
| 123 | PTP | Performance Transparency Protocol | (Welzl) |
| 124 | ISIS over IPv4 | | (Przygienda) |
| 125 | FIRE | | (Partridge) |
| 126 | CRTP | Combat Radio Transport Protocol | (Sautter) |
| 127 | CRUDP | Combat Radio User Datagram | (Sautter) |
| 128 | SSCOPMCE | | (Waber) |
| 129 | IPLT | | (Hollbach) |
| 130 | SPS | Secure Packet Shield | (McIntosh) |
| 131 | PIPE | Private IP Encapsulation within IP | (Petri) |
| 132 | SCTP | Stream Control Transmission Protocol | (Stewart) |
| 133 | FC | Fibre Channel | (Rajagopal) |
| 134 | RSVP-E2E-IGNORE | | (RFC3175) |
| 135 | Mobility Header | | (RFC3775) |
| 136 | UDPLite | | (RFC3828) |
| 137 | MPLS-in-IP | | (RFC4023) |
| 138 | manet | MANET Protocols | (RFC-ietf-manet-iana-07.txt) |
| 139 | HIP | Host Identity Protocol | (RFC5201) |
| 140~252 | | Unassigned | (IANA) |
| 253 | | Use for experimentation and testing | (RFC3692) |
| 254 | | Use for experimentation and testing | (RFC3692) |
| 255 | Reserved | | (IANA) |
- Options 항목은 32bit로 정렬되어야 한다.
- Type of service (TOS) : 각 응용의 종류에 따라 권장되는 값은 아래와 같다.
| Application | Minimize delay | Maximize throughput | Maximize reliability | Minimize monetary cost | Hex value |
| Telnet/Rlogin | 1 | 0 | 0 | 0 | 10H |
| FTP control | 1 | 0 | 0 | 0 | 10H |
| FTP data | 0 | 1 | 0 | 0 | 08H |
| any bulk data | 0 | 1 | 0 | 0 | 08H |
| TFTP | 1 | 0 | 0 | 0 | 10H |
| SMTP command phase | 1 | 0 | 0 | 0 | 10H |
| SMTP data phase | 0 | 1 | 0 | 0 | 08H |
| DNS UDP query | 1 | 0 | 0 | 0 | 10H |
| DNS TCP query | 0 | 0 | 0 | 0 | 00H |
| DNS zone transfer | 0 | 1 | 0 | 0 | 08H |
| ICMP error | 0 | 0 | 0 | 0 | 00H |
| ICMP query | 0 | 0 | 0 | 0 | 00H |
| any IGP | 0 | 0 | 1 | 0 | 04H |
| SNMP | 0 | 0 | 1 | 0 | 04H |
| BOOTP | 0 | 0 | 0 | 0 | 00H |
| NNTP | 0 | 0 | 0 | 1 | 02H |
2008년 9월 1일 현재 IANA protocol-numbers ¶
- IANA protocol-numbers 를 보시려면 여기를 클릭해주세요.
Protocol Numbers
(last updated 2008-04-18)
Registries included below:
- Assigned Internet Protocol Numbers
Registry Name: Assigned Internet Protocol Numbers
Reference: [RFC5237]
Registration Procedures: IESG Approval or Standards Action
Note: In the Internet Protocol version 4 (IPv4) [RFC791] there is a field
called "Protocol" to identify the next level protocol. This is an 8
bit field. In Internet Protocol version 6 (IPv6) [RFC1883], this field
is called the "Next Header" field.
Registry:
Decimal Keyword Protocol References
------- --------------- --------------------------------------- ------------------
0 HOPOPT IPv6 Hop-by-Hop Option [RFC1883]
1 ICMP Internet Control Message [RFC792]
2 IGMP Internet Group Management [RFC1112]
3 GGP Gateway-to-Gateway [RFC823]
4 IP IP in IP (encapsulation) [RFC2003]
5 ST Stream [RFC1190][RFC1819]
6 TCP Transmission Control [RFC793]
7 CBT CBT [Ballardie]
8 EGP Exterior Gateway Protocol [RFC888][DLM1]
9 IGP any private interior gateway [IANA]
(used by Cisco for their IGRP)
10 BBN-RCC-MON BBN RCC Monitoring [SGC]
11 NVP-II Network Voice Protocol [RFC741][SC3]
12 PUP PUP [PUP][XEROX]
13 ARGUS ARGUS [RWS4]
14 EMCON EMCON [BN7]
15 XNET Cross Net Debugger [IEN158][JFH2]
16 CHAOS Chaos [NC3]
17 UDP User Datagram [RFC768][JBP]
18 MUX Multiplexing [IEN90][JBP]
19 DCN-MEAS DCN Measurement Subsystems [DLM1]
20 HMP Host Monitoring [RFC869][RH6]
21 PRM Packet Radio Measurement [ZSU]
22 XNS-IDP XEROX NS IDP [ETHERNET][XEROX]
23 TRUNK-1 Trunk-1 [BWB6]
24 TRUNK-2 Trunk-2 [BWB6]
25 LEAF-1 Leaf-1 [BWB6]
26 LEAF-2 Leaf-2 [BWB6]
27 RDP Reliable Data Protocol [RFC908][RH6]
28 IRTP Internet Reliable Transaction [RFC938][TXM]
29 ISO-TP4 ISO Transport Protocol Class 4 [RFC905][RC77]
30 NETBLT Bulk Data Transfer Protocol [RFC969][DDC1]
31 MFE-NSP MFE Network Services Protocol [MFENET][BCH2]
32 MERIT-INP MERIT Internodal Protocol [HWB]
33 DCCP Datagram Congestion Control Protocol [RFC4340]
34 3PC Third Party Connect Protocol [SAF3]
35 IDPR Inter-Domain Policy Routing Protocol [MXS1]
36 XTP XTP [GXC]
37 DDP Datagram Delivery Protocol [WXC]
38 IDPR-CMTP IDPR Control Message Transport Proto [MXS1]
39 TP++ TP++ Transport Protocol [DXF]
40 IL IL Transport Protocol [Presotto]
41 IPv6 Ipv6 [Deering]
42 SDRP Source Demand Routing Protocol [DXE1]
43 IPv6-Route Routing Header for IPv6 [Deering]
44 IPv6-Frag Fragment Header for IPv6 [Deering]
45 IDRP Inter-Domain Routing Protocol [Hares]
46 RSVP Reservation Protocol [Braden]
47 GRE General Routing Encapsulation [Li]
48 DSR Dynamic Source Routing Protocol [RFC4728]
49 BNA BNA [Salamon]
50 ESP Encap Security Payload [RFC2406]
51 AH Authentication Header [RFC2402]
52 I-NLSP Integrated Net Layer Security TUBA [GLENN]
53 SWIPE IP with Encryption [JI6]
54 NARP NBMA Address Resolution Protocol [RFC1735]
55 MOBILE IP Mobility [Perkins]
56 TLSP Transport Layer Security Protocol [Oberg]
using Kryptonet key management
57 SKIP SKIP [Markson]
58 IPv6-ICMP ICMP for IPv6 [RFC1883]
59 IPv6-NoNxt No Next Header for IPv6 [RFC1883]
60 IPv6-Opts Destination Options for IPv6 [RFC1883]
61 any host internal protocol [IANA]
62 CFTP CFTP [CFTP][HCF2]
63 any local network [IANA]
64 SAT-EXPAK SATNET and Backroom EXPAK [SHB]
65 KRYPTOLAN Kryptolan [PXL1]
66 RVD MIT Remote Virtual Disk Protocol [MBG]
67 IPPC Internet Pluribus Packet Core [SHB]
68 any distributed file system [IANA]
69 SAT-MON SATNET Monitoring [SHB]
70 VISA VISA Protocol [GXT1]
71 IPCV Internet Packet Core Utility [SHB]
72 CPNX Computer Protocol Network Executive [DXM2]
73 CPHB Computer Protocol Heart Beat [DXM2]
74 WSN Wang Span Network [VXD]
75 PVP Packet Video Protocol [SC3]
76 BR-SAT-MON Backroom SATNET Monitoring [SHB]
77 SUN-ND SUN ND PROTOCOL-Temporary [WM3]
78 WB-MON WIDEBAND Monitoring [SHB]
79 WB-EXPAK WIDEBAND EXPAK [SHB]
80 ISO-IP ISO Internet Protocol [MTR]
81 VMTP VMTP [DRC3]
82 SECURE-VMTP SECURE-VMTP [DRC3]
83 VINES VINES [BXH]
84 TTP TTP [JXS]
85 NSFNET-IGP NSFNET-IGP [HWB]
86 DGP Dissimilar Gateway Protocol [DGP][ML109]
87 TCF TCF [GAL5]
88 EIGRP EIGRP [CISCO][GXS]
89 OSPFIGP OSPFIGP [RFC1583][JTM4]
90 Sprite-RPC Sprite RPC Protocol [SPRITE][BXW]
91 LARP Locus Address Resolution Protocol [BXH]
92 MTP Multicast Transport Protocol [SXA]
93 AX.25 AX.25 Frames [BK29]
94 IPIP IP-within-IP Encapsulation Protocol [JI6]
95 MICP Mobile Internetworking Control Pro. [JI6]
96 SCC-SP Semaphore Communications Sec. Pro. [HXH]
97 ETHERIP Ethernet-within-IP Encapsulation [RFC3378]
98 ENCAP Encapsulation Header [RFC1241,RXB3]
99 any private encryption scheme [IANA]
100 GMTP GMTP [RXB5]
101 IFMP Ipsilon Flow Management Protocol [Hinden]
102 PNNI PNNI over IP [Callon]
103 PIM Protocol Independent Multicast [Farinacci]
104 ARIS ARIS [Feldman]
105 SCPS SCPS [Durst]
106 QNX QNX [Hunter]
107 A/N Active Networks [Braden]
108 IPComp IP Payload Compression Protocol [RFC2393]
109 SNP Sitara Networks Protocol [Sridhar]
110 Compaq-Peer Compaq Peer Protocol [Volpe]
111 IPX-in-IP IPX in IP [Lee]
112 VRRP Virtual Router Redundancy Protocol [RFC3768]
113 PGM PGM Reliable Transport Protocol [Speakman]
114 any 0-hop protocol [IANA]
115 L2TP Layer Two Tunneling Protocol [Aboba]
116 DDX D-II Data Exchange (DDX) [Worley]
117 IATP Interactive Agent Transfer Protocol [Murphy]
118 STP Schedule Transfer Protocol [JMP]
119 SRP SpectraLink Radio Protocol [Hamilton]
120 UTI UTI [Lothberg]
121 SMP Simple Message Protocol [Ekblad]
122 SM SM [Crowcroft]
123 PTP Performance Transparency Protocol [Welzl]
124 ISIS over IPv4 [Przygienda]
125 FIRE [Partridge]
126 CRTP Combat Radio Transport Protocol [Sautter]
127 CRUDP Combat Radio User Datagram [Sautter]
128 SSCOPMCE [Waber]
129 IPLT [Hollbach]
130 SPS Secure Packet Shield [McIntosh]
131 PIPE Private IP Encapsulation within IP [Petri]
132 SCTP Stream Control Transmission Protocol [Stewart]
133 FC Fibre Channel [Rajagopal]
134 RSVP-E2E-IGNORE [RFC3175]
135 Mobility Header [RFC3775]
136 UDPLite [RFC3828]
137 MPLS-in-IP [RFC4023]
138 manet MANET Protocols [RFC-ietf-manet-iana-07.txt]
139 HIP Host Identity Protocol [RFC5201]
140-252 Unassigned [IANA]
253 Use for experimentation and testing [RFC3692]
254 Use for experimentation and testing [RFC3692]
255 Reserved [IANA]
References
----------
[CFTP] Forsdick, H., "CFTP", Network Message, Bolt Beranek and
Newman, January 1982.
[CISCO] Cisco Systems, "Gateway Server Reference Manual", Manual
Revision B, January 10, 1988.
[DDN] Feinler, E., Editor, "DDN Protocol Handbook", Network
Information Center, SRI International, December 1985.
[DGP] M/A-COM Government Systems, "Dissimilar Gateway Protocol
Specification, Draft Version", Contract no. CS901145,
November 16, 1987.
[ETHERNET] "The Ethernet, A Local Area Network: Data Link Layer and
Physical Layer Specification", AA-K759B-TK, Digital
Equipment Corporation, Maynard, MA. Also as: "The
Ethernet - A Local Area Network", Version 1.0, Digital
Equipment Corporation, Intel Corporation, Xerox
Corporation, September 1980. And: "The Ethernet, A Local
Area Network: Data Link Layer and Physical Layer
Specifications", Digital, Intel and Xerox, November 1982.
And: XEROX, "The Ethernet, A Local Area Network: Data Link
Layer and Physical Layer Specification", X3T51/80-50,
Xerox Corporation, Stamford, CT., October 1980.
[IEN90] Cohen, D. and J. Postel, "Multiplexing Protocol", IEN 90,
USC/Information Sciences Institute, May 1979.
[IEN119] Forgie, J., "ST - A Proposed Internet Stream Protocol",
IEN 119, MIT Lincoln Laboratory, September 1979.
[IEN158] Haverty, J., "XNET Formats for Internet Protocol Version 4",
IEN 158, October 1980.
[MFENET] Shuttleworth, B., "A Documentary of MFENet, a National
Computer Network", UCRL-52317, Lawrence Livermore Labs,
Livermore, California, June 1977.
[PUP] Boggs, D., J. Shoch, E. Taft, and R. Metcalfe, "PUP: An
Internetwork Architecture", XEROX Palo Alto Research Center,
CSL-79-10, July 1979; also in IEEE Transactions on
Communication, Volume COM-28, Number 4, April 1980.
[SPRITE] Welch, B., "The Sprite Remote Procedure Call System",
Technical Report, UCB/Computer Science Dept., 86/302,
University of California at Berkeley, June 1986.
[RFC741] Cohen, D., "Specifications for the Network Voice Protocol",
RFC 741, ISI/RR 7539, USC/Information Sciences Institute,
March 1976.
[RFC768] Postel, J., "User Datagram Protocol", STD 6, RFC 768,
USC/Information Sciences Institute, August 1980.
[RFC791] Postel, J., "Internet Protocol - DARPA Internet Prnogram
Protocol Specification", STD 5, RFC 791, DARPA, September
1981.
[RFC792] Postel, J., "Internet Control Message Protocol - DARPA
Internet Program Protocol Specification", STD 5, RFC 792,
USC/Information Sciences Institute, September 1981.
[RFC793] Postel, J., "Transmission Control Protocol - DARPA
Internet Program Protocol Specification", STD 7, RFC 793,
USC/Information Sciences Institute, September 1981.
[RFC823] Hinden, R., and A. Sheltzer, "The DARPA Internet Gateway",
RFC 823, BBN, September 1982.
[RFC869] Hinden, R., "A Host Monitoring Protocol", RFC 869,
Bolt Beranek and Newman, December 1983.
[RFC888] Seamonson, L., and E. Rosen, "STUB" Exterior Gateway
Protocol", RFC 888, BBN Communications Corporation,
January 1984.
[RFC905] International Standards Organization, "ISO Transport Protocol
Specification - ISO DP 8073", RFC 905, April 1984.
[RFC908] Velten, D., R. Hinden, and J. Sax, "Reliable Data Protocol",
RFC 908, BBN Communications Corporation, July 1984.
[RFC938] Miller, T., "Internet Reliable Transaction Protocol", RFC 938,
ACC, February 1985.
[RFC969] Clark, D., M. Lambert, and L. Zhang, "NETBLT: A Bulk Data
Transfer Protocol", RFC 969, MIT Laboratory for Computer
Science, December 1985.
[RFC1112] Deering, S., "Host Extensions for IP Multicasting",
STD 5, RFC 1112, Stanford University, August 1989.
[RFC1190] Topolcic, C., Editor, "Experimental Internet Stream
Protocol, Version 2 (ST-II)", RFC 1190, CIP Working Group,
October 1990.
[RFC1241] Woodburn, W., and D. Mills, " A Scheme for an Internet
Encapsulation Protocol: Version 1", RFC 1241, SAIC,
University of Delaware, July 1991.
[RFC1583] Moy, J., "The OSPF Specification", RFC 1583, Proteon,
March 1994.
[RFC1735] Heinanen, J., and R. Govindan, " NBMA Address Resolution
Protocol (NARP)", RFC 1735, Telecom Finland and USC/ISI,
December 1994.
[RFC1819] L. Delgrossi, L. Berger, and ST2 Working Group, "Internet
Stream Protocol Version 2 (ST2) Protocol Specification
- Version ST2+", RFC 1819, August 1995.
[RFC1883] Deering, S., and R. Hinden, "Internet Protocol, Version 6
(IPv6) Specification", RFC 1883, Xerox PARC, Ipsilon
Networks, December 1995.
[RFC2003] Perkins, C., "IP Encapsulation within IP", RFC 2003, IBM,
September 1996.
[RFC2393] Shacham, A., and R. Monsour, R. Pereira, M. Thomas, "IP
Payload Compression Protocol (IPComp)", RFC 2393, Cisco,
Hi/fn, TimeStep, AltaVista Internt, December 1998.
[RFC2402] S. Kent and R. Atkinson, "IP Authentication Header",
RFC 2402, November 1998.
[RFC2406] S. Kent and R. Atkinson, "IP Encapsulating Security Payload (ESP)",
RFC 2406, November 1998.
[RFC3175] F. Baker, C. Iturralde, F. Le Faucheur, B. Davie,
"Aggregation of RSVP for IPv4 and IPv6 Reservations",
RFC 3175, September 2001.
[RFC3378] R. Housley and S. Hollenbeck, "EtherIP: Tunneling Ethernet
Frames in IP Datagrams", RFC 3378, September 2002.
[RFC3692] T. Narten, "Assigning Experimental and Testing Numbers Considered
Useful", RFC 3692, January 2004.
[RFC3768] R. Hinden, Ed., "Virtual Router Redundancy Protocol (VRRP)",
RFC 3768, April 2004.
[RFC3775] D. Johnson, C. Perkins, and J. Arkko, "Mobility Support in IPv6",
RFC 3775, June 2004.
[RFC3828] L-A. Larzon, M. Degermark, S. Pink, L-E. Jonsson Ed., and
G. Fairhurst, Ed., "The UDP-Lite Protocol", RFC 3828, July 2004.
[RFC4023] T. Worster, Y. Rekhter, and E. Rosen, Ed., "Encapsulating MPLS in
IP or Generic Routing Encapsulation (GRE)", RFC 4023, March 2005.
[RFC4340] E. Kohler, M. Handley and S. Floyd, "Datagram Congestion
Control Protocol (DCCP)", RFC 4340, March 2006.
[RFC4728] D.B. Johnson, D.A. Maltz and Y-C. Hu, "The Dynamic Source Routing Protocol
for Mobile Ad Hoc Networks (DSR)", RFC 4728, February 2007.
[RFC-ietf-manet-iana-07.txt]
I. Chakeres, "IANA Allocations for MANET Protocols", RFC XXXX,
Month Year.
[RFC5201] R. Moskowitz, P. Nikander, P. Jokela, Ed., T. Henderson, "Host Identity
Protocol", RFC 5201, April 2008.
[RFC5237] J. Arkko, S. Bradner, "IANA Allocation Guidelines for the Protocol Field",
RFC 5237, February 2008.
People
------
[Aboba] Bernard Aboba <bernardaµsoft.com>, April 1998.
[Ballardie] Tony Ballardie <A.Ballardie&cs.ucl.ac.uk>
[BCH2] Barry Howard <Howard&NMFECC.LLNL.GOV>
[BK29] Brian Kantor <brian&UCSD.EDU>
[BN7] <mystery contact>
[Braden] Bob Braden, <braden&isi.edu>, July 1997.
[BWB6] Barry Boehm <boehm&ARPA.MIL>
[BXH] Brian Horn
[BXW] Bruce Willins
[Callon] Ross Callon, <rcallon&baynetworks.com>, December 1995.
[Carpenter] Brian Carpenter, <brian&dxcoms.cern.ch>, January 1995.
[Crowcroft] Jon Crowcroft <jon&cs.ucl.ac.uk>, June 1999.
[DDC1] David Clark <ddc&LCS.MIT.EDU>
[Deering] Steve Deering, <deering&parc.xerox.com>, March 1995.
[DLM1] David Mills <Mills&HUEY.UDEL.EDU>
[Doraswamy] Naganand Doraswamy, <naganand&BayNetworks.com>, September 1997.
[DRC3] Dave Cheriton <cheriton&PESCADERO.STANFORD.EDU>
[Durst] Robert Durst, <durst&mitre.org>, March 1997.
[DXE1] Deborah Estrin <estrin&usc.edu>
[DXF] Dirk Fromhein <df&watershed.com>
[DXM2] David Mittnacht
[Ekblad] Leif Ekblad <leif.ekblad&eslov.mail.telia.com>, March 1999.
[Farinacci] Dino Farinacci, <dino&cisco.com>, March 1996.
[Feldman] Nancy Feldman <nkf&vnet.ibm.com> January 1997.
[GAL5] Guillermo A. Loyola <LOYOLA&IBM.COM>
[GLENN] K. Robert Glenn <glenn&osi.ncsl.nist.gov>
[GXC] Greg Chesson <Greg&SGI.COM>
[GXS] Guenther Schreiner <snmp-admin&ira.uka.de>
[GXT1] Gene Tsudik <tsudik&USC.EDU>
[Hamilton] Mark Hamilton <mah&spectralink.com>, November 1998.
[Hares] Sue Hares <skh&merit.edu>
[HCF2] Harry Forsdick <Forsdick&BBN.COM>
[Hinden] Bob Hinden, <hinden&ipsilon.com>, November 1995, 1997.
[Hunter] Michael Hunter, <mphunter&qnx.com>, July 1997.
[HWB] Hans-Werner Braun <HWB&MCR.UMICH.EDU>
[HXH] Howard Hart <hch&hybrid.com>
[IANA] Internet Assigned Numbers Authority, <iana&iana.org>, June 1995.
[JBP] Jon Postel <postel&isi.edu>
[JMP] Jean-Michel Pittet, <jmp&gandalf.engr.sgi.com>, November 1998.
[JC120] <mystery contact>
[JFH2] Jack Haverty <jhaverty&ORACLE.COM>
[JI6] John Ioannidis <ji&CS.COLUMBIA.EDU>
[JTM4] John Moy <jmoy&PROTEON.COM>
[JWF] Jim Forgie <FORGIE&XN.LL.MIT.EDU>
[JXS] Jim Stevens <Stevens&ISI.EDU>
[KATZ] Dave Katz <dkatz&cisco.com>
[Lee] CJ Lee, <cj_lee&novell.com>, October 1997.
[Li] Tony Li <tli&cisco.com>
[Lothberg] Peter Lothberg <roll&stupi.se>, March 1999.
[Markson] Tom Markson, <markson&osmosys.ingog.com>, September 1995.
[MB] Mike Brescia <Brescia&CCV.BBN.COM>
[MBG] Michael Greenwald <Greenwald&SCRC-STONY-BROOK.SYMBOLICS.COM>
[McIntosh] Bill McIntosh <BMcIntosh&fortresstech.com>
[ML109] Mike Little <little&MACOM4.ARPA>
[MTR] Marshall T. Rose <mrose&dbc.mtview.ca.us>
[Murphy] John Murphy <john.m.murphy&mci.com>, October 1998.
[MXS1] Martha Steenstrup <MSteenst&BBN.COM>
[NC3] J. Noel Chiappa <JNC&XX.LCS.MIT.EDU>
[Oberg] Christer Oberg <chg&bull.se> October 1994.
[Partridge] Criag Partridge <craig&bbn.com>, August 1999.
[Perkins] Charlie Perkins <perk&watson.ibm.com>, October 1994.
[Petri] Bernhard Petri <bernhard.petri&nsn.com>, March 2000.
[Presotto] Dave Presotto <presotto&plan9.att.com>, July 1995.
[Przygienda] Tony Przygienda <prz&siara.com>, August 1999.
[PXL1] Paul Liu
[Rajagopal] Murali Rajagopal, <murali&gadzoox.com>, May 2000.
[RH6] Robert Hinden <Hinden&ENG.SUN.COM>
[RTB3] Bob Braden <braden&isi.edu>
[RC77] <mystery contact>
[RDH1] Russ Housley <rhousley&rsasecurity.com>
[RWS4] Robert W. Scheifler <RWS&XX.LCS.MIT.EDU>
[RXB3] Robert Woodburn <woody&cseic.saic.com>
[Sautter] Robert Sautter <rsautter&acdnj.itt.com>, August 1999.
[SAF3] Stuart A. Friedberg <stuart&CS.WISC.EDU>
[Salamon] Gary Salamon
[SC3] Steve Casner <casner&isi.edu>
[SGC] Steve Chipman Chipman&F.BBN.COM>
[SHB] Steven Blumenthal <BLUMENTHAL&VAX.BBN.COM>
[Speakman] Tony Speakman <speakman&cisco.com>, January 1998.
[Sridhar] Manickam R.Sridhar <msridhar&sitaranetworks.com>, September 1997.
[Stewart] Randall R. Stewart <rrs&cisco.com>, April 2000.
[SXA] Susie Armstrong <Armstrong.wbst128&XEROX.COM>
[SXD] Steve Deering <deering&PARC.XEROX.COM>
[TXM] Trudy Miller <Trudy&ACC.COM>
[Volpe] Victor Volpe <vvolpe&smtp.microcom.com>, October 1997.
[VXD] Victor Dafoulas
[Waber] Kurt Waber <kurt.waber&swisscom.com>, August 1999.
[Welzl] Michael Welzl <michael&tk.uni-linz.ac.at>, August 1999.
[WM3] William Melohn <Melohn&SUN.COM>
[WXC] Wesley Craig <Wesley.Craig&terminator.cc.umich.edu>
[Worley] John Worley <worley&milehigh.net>, June 1998.
[ZSU] Zaw-Sing Su <ZSu&TSCA.ISTC.SRI.>
[]
|
|